History and tools missing

Since before the Xmas holidays, after my login, my history is no longer displayed on the right side of the Galaxy browser window. However, in User=>Datasets I can still see all the history’s datasets, the status of latest analysis/dataset I had worked with is given as “current history” in User=>Histories. Memory usage in the upper right corner of the Galaxy browser window says “Using 0%” and that I should log in for details, though I am logged in.
Second, pretty much most of the tools in the Tools column of the Galaxy Browser window do no longer open when I click them, the central part of the Galaxy Browser window remains blank.
Same problems in both Safari and Firefox.
Any advice on fixing those problems will be greatly appreciated.

PS: this is when using usegalaxy.org

1 Like

I’m having the same problem (Chrome and Edge). Also it says my storage usage is 0%. Help!

Hi @jmuser and @chart4

The UseGalaxy.org server did have some connection trouble earlier. Please try logging in again now. You might need to restart your web browser first to establish a new connection.

If this continues, please let us know. Some screenshots might help.

Thanks for the response. The problem persists also after restart of the browser, still the same issues after login.
Attached are 4 screenshots:
1: After login => the right column where the history is supposed to be displayed is blank
2: Saved histories => there is a current history that should be displayed
3: Datasets => there are several datasets in the current history
4: After selecting, for instance, the Intersect tool => the central part of the browser window is blank when it should display data input fields and parameters and stuff


I restarted my web browser, I tried a different browser (Edge, I normally use Chrome), I restarted my computer. I updated and restarted my computer. The problem persists. Any advice on how to solve this is appreciated.

Here are some screen shots. First, when I click on Histories under User. Second, when I click on View for any history. Third, when I click on Fetch closest non-overlapping feature under Operate on Genomic Intervals.


Hi @jmuser and @chart4

Please double check that cookies are enabled. Also, the best browsers are: Safari, Chrome, Firefox.

Thanks for the response. I’m using Chrome and cookies are enabled. I updated Chrome and restarted. I tried using 2 different computers that I have used Galaxy on in the past (one with uBlock Origin but disabled for Galaxy, the other without any blocker). I tried Firefox on a VM (Ubuntu). Still can’t get the history to load on either computer. Could something in my account be broken?


I should mention that History shows up in the right column when I am not logged in and go to usegalaxy.org, but of course it is empty and shows Unnamed history. Screenshot below.

Hi @chart4 – yes, I can look at your account. Send an email to galaxy-bugs@lists.galaxyproject.org from your registered account email address and include a link to this topic so I can connect the two. Same goes for others with problems. I don’t do account reviews through the forum directly for a raft of reasons…

The other thing I can think of is that our content is being blocked by whoever is hosting your internet. If you are connecting through an institutional IP, you could check with them about this, and they might have other complaints already (would impact everyone). Sometimes “things change” around the start of a new year… so early January for new troubles can be one symptom of that. The usual solution is just allowlist our site. They can contact us at that same mailing list if needed.


I just tried using Galaxy at home, still the same issue. So it isn’t a New Year change at my institution, but it was worth a try. I’ll contact you via Galaxy-bugs, as you requested.


pretty much the same as described by chart4, problems independent of cookies and network from which I am accessing usegalaxy.org.
I will send an e-mail to galaxy-bugs.

Hi @chart4

Thanks for sending the email. We found the problem – is a small bug that we are working on today.

And, Hi @jmuser

Thanks for sending in an email as well! It is the same issue.

Once this is done, everyone impacted will have the fix applied, not just people who wrote in.

Thanks for the followup!

Thanks a lot! Very much appreciated!

You are probably aware of this, but I still can’t access my history or do anything in my account at Galaxy. Is there any estimate of when the bug will be fixed?

1 Like

Hi @chart4

We found that this is a client bug. That means the web browser is not connecting to the server correctly.

This is not a great solution but should work: open up the developer javascript console in your web browser while logged into your account. This persists the connection. I’m not sure if you need to clear your browser cache first or not but that is what I would try if the console is not enough.

When using Chrome, find that under View → Developer → JavaScript Console.

Our apologies! Unexpected but actual, and we are working on it.

Still no luck. I cleared my cache and reopened Chrome, but my memory doesn’t load. Here is a message I get:

failed to load user
i {message: ‘Request failed with status code 500’, name: ‘AxiosError’, code: ‘ERR_BAD_RESPONSE’, config: {…}, request: XMLHttpRequest, …}

500 (Internal Server Error)

Uncaught (in promise) Error: A listener indicated an asynchronous response by returning true, but the message channel closed before a response was received

I’m not skilled enough with scripting to know if this is useful for you, but thanks for all of your responses!

1 Like

Update: I should be more clear, that panel has to stay open. Maybe that is how you captured the message. I am going to share that that with our team. SO Sorry for the hassles!

Is the developer console open?

This is not the final solution, just a work-around for the next few days. I didn’t want to leave this without anything over the weekend.

Yes, I left the developer panel open. I also tried logging out and back in again with the panel open, and opening the panel while logged out then logging in, and leaving it open while I did other things to see if it took time. Unfortunately nothing helped.

Hi @jennaj,
Pretty much the same here as described by @chart4, in Safari in my case.

I am getting the following output in the console:

[Log] JQMIGRATE: Migrate is installed with logging active, version 1.4.1 (libs.bundled.js, line 2)
[Warning] accessing (get) window.Galaxy – “/” (analysis.bundled.js, line 2)
[Log] The Galaxy console has been disabled. You can enable it by running enableDebugging() in devtools. (analysis.bundled.js, line 2)
[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (current, line 0)
[Error] Failed to load resource: the server responded with a status of 500 (Internal Server Error) (3773ff8bdff087a1, line 0)

1 Like

We are applying the fix right now. The problem was not having a username set (was possible in the very early days). We are creating one for you based on the email address, but you can update that later on to be whatever you want. I’ll post back once ready.