Human Cell Atlas Downloading Data Troubleshooting

I am trying to use the Human Cell Atlas Matrix Downloader but am having trouble and was hoping to get some advice!

When I use the downloader for the following dataset (Project Label: HeartSingleCellsAndNucleiSeq, link: [here]) the tool errors, saying that the project could not be found in the database. I have tried both the Project label and title. Is there something more I am missing?


Hi @kdwyer

Please try sharing the data link again so we can help you to find the correct term to use. A screenshot might also help – be sure to capture the entire tool form, especially the top with the tool name/version. Also please confirm you are working at and not at a different server.

@jennaj Thanks so much for your reply! I would be happy to provide the information.

I confirm that I am working at!

The link to the dataset is here:

I have tried both the project title (Cells of the adult human heart) and project label (HeartSingleCellsAndNucleiSeq) but each time the error is that the project identifier was not found in the database. I included screenshots below:

I really appreciate any advice you have!

Hi @kdwyer

Great, thank you. I’m not sure exactly which key is expected … but let’s investigate more.

Start by downloading the Metadata file they host into a history, then share it back unless you figure it out first! You can put just that file along with your tests in the same history (only) when sharing it. All of the data is public anyway. Sharing your History

I can probably dig into the code and test cases to clear things up with that more info as needed.

Hi @jennaj,
I tried downloading the metadata but they only have the file manifest

I also have the link to my history Galaxy | Europe
Is that what you were looking for or should I so something more?

That would be great if you are able to dig into the code and test some cases, thank you so very much!

Let me know if there is any more I should do or try,

Hi @kdwyer

The manifest seems to be what to get. You should be able to copy/paste that into the Upload tool to get it into Galaxy.

Then do a review – and maybe a few tests. If you get stuck, then come back and we can go through it together. I’m guessing this is something that can be figured out without code hunting but I also haven’t used this tool before or reviewed even the tool form yet :stuck_out_tongue:. But all tools are “the same” in this way – try and see what happens first, then dig more.

Hi @jennaj,
Thanks so much for you patience! I uploaded the metadata file manifest into Galaxy and re-tested (i.e. different names, matrix market vs. loom and different versions of the tool) but it is all producing errors. I would be so appreciative if we could walk through it together!


Hi @kdwyer

After running some tests, including the default example on the tool form (which worked fine), I think that this specific data is not publicly available. The correct query at the top of the form should be this but it fails. My history with tests:

Cells of the adult human heart

I see that there is a Slack channel for the project. Since I’m not a member, I couldn’t ask a question or search it. But maybe you can? Not sure how else to help here. Contacting the people that host the data seems like the best way to get a definitive answer.

So … my guess that it is private is based on this: primary metadata wasn’t available, other projects download Ok, and the key is correct for the Galaxy tool. Private data cannot be used at any public Galaxy server but can at certain private Galaxy servers. AnVIL is one example, and the Terra project you see at that website is involved. So you could reach out through those channels too.

Hope that helps, and I’m a bit sad I couldn’t get you a better answer. Should you figure out how to do this at a public server after getting more help, a post back here with the how-to would be appreciated :slight_smile: