Is BWA-meth alignment on PE50 possible?

Hello, has anyone managed to use BWA-meth with PE-50 reads?

I’ve previously successfully used BWA-meth for aligning Illumina PE-150 reduced representation bisulfite sequence (RRBS) files with human and mouse genomes.

However today’s attempt at aligning PE-50 RRBS reads to the rat genome (rn6 or rn7) didn’t work.
Most error messages just had " An error occurred with this dataset:
format bam database [?]
Unable to finish job"

But some gave a bit more information:
" An error occurred with this dataset:
format bam database [?]
converting c2t in index_dir/genome.fa to index_dir/genome.fa.bwameth.c2t
indexing with bwa-mem: index_dir/genome.fa.bwameth.c2t
[bwa_index] Pack FASTA… 49.37 sec
[bwa_index] Construct BWT for the packed sequence…
[BWTIncCreate] textLength=10591662912 "

I’m thinking that the aligner doesn’t work with 50-nucleotide long reads and needs longer reads. Can anyone help?

Hi @neily
maybe map 50nt long reads on human or mouse genome. Select 1k PE150 reads (first 4k lines), map to the genome of choice, trim to 50nt (Trimmomatic, option CROP or HEADCROP) and map to the same genome.
Hope that gives you the answer.
Kind regards,

1 Like

Thanks Igor, I did a similar test with all the reads in the files which previously worked cropped from 150nt to 50nt. It failed and I saw in the error in the dataset error report (after clicking the beetle/ladybird icon) the following text

" WARNING: 2000 reads with length < 80
: this program is designed for long reads "

So it seems that BWA-meth doesn’t like 50nt reads. However, there may be other problems with BWA-meth at the moment, so I will update this thread once that issue is sorted as it could be that when fixed, BWA-meth can still align 50nt reads, it just isn’t optimised for it.

As an update for anyone interested, Igor figured out the problem. BWAmeth didn’t run at all on Galaxy Version 0.2.6+galaxy0. So when I changed to Galaxy Version 0.2.3+galaxy0 it worked fine.

I changed the tool version during job setup: click at Version (three blocks icon) at the top right corner of the middle window.

So it seems that while BWAmeth prefers reads>80nt it can still run with 50nt reads.