Is Samtools Faidx Available on Galaxy US?

I need to index a fasta chromosome for use in IGV. Their instructions state to use Samtools faidx, but I don’t see it listed as a tool on the server. Is it available?

I have been using IGV to evaluate tansposon insertion frequencies in an E. coli genome. I had a properly working session open for some time, but had to close it for a reboot. The saved sessions no longer load properly (the old chromosome loads along with the insertion site track and anotation track, but the wiggle files are flat lines. Searches revelaed that there may be an incompatible java font size in the saved session, so I elected to start a new session, but now I can’t load the reference chromosome to begin. I then elected to generate a new chrom reference to start a fresh session (with new matching chrom identifiers), but IGV requires an index of the same fasta (specifically recommended Samtools).

Hi @sdmoore

Click on the pencil icon for your fasta dataset to find the function that will put a fasta index into your history. Note: this doesn’t replace or interact with a custom build in Galaxy, but can be a complimentary file to getting a specific genome indexed in both applications.

You can even do things like:

  1. Create the custom genome in IGV
  2. Create the custom genome in Galaxy
  3. Give both the same “dbkey” and you can click to view datasets from Galaxy in IGV (using the visualize icon).

So, use Galaxy to create the inputs that IVG wants, and use the custom build function to create the index native to Galaxy (will be specific to your account, only).

For the custom function in Galaxy, please see → FAQ: How to use Custom Reference Genomes?

And, help with navigation → FAQ: Different dataset icons and their usage

Hope that helps! Let us know if you get stuck and we can help to troubleshoot. All this worked fine last time I tried it. :slight_smile:

1 Like

Thanks for this - I will try that out.


Thanks Again. I ran into the same corner:

Clicking the pencil, then Datatypes tab, then create the fai - that works. But, trying to load that fasta and fai into IGV gives perpetual spinning wheel (although the genome length populates). I think this is an IGV import issue and I will look elsewhere for help.

Right – I think I had to download the files to my computer, then use them locally with my local IGV application. I can’t remember if this was a limitation on the IGV side of not wanting to use a remote URL for the data or not. Technically, the file inside Galaxy is a publicly hosted data link so if an application accepts a public URL file, hosting that from Galaxy works fine.

Small note: depending how you set up the server permissions, you might need to set a history to a “shared” state to use file URL as public.

Anyway, hope this works out!