Metilene tool usage

Hello there!

I am working with WGBS data and I want to extract the DMRs in a particular mutant.
I used bwameth to align the sequencing data to mm10 genome. After that, I sorted the alignment file and used methyldackel to see the methylation status. I used the metilene tool to extract DMRs but this doesn’t work. I get an error message like this
" null device 1 [WARNING] Tue Aug 9, 16:7:8, 2022 Input files need to be SORTED, i.e., use “bedtools sort -i file >file.sorted”. I sorted the methyldackel output files using Sortbed and ran metilene again. Same error message. I read from the manual for Metilene, that the input file has to be in a certain format and the input file can be prepared using bedtools unionbedg. But this tool is not present in usegalaxy.eu or .org. Can anyone help me to prepare the input files for metilene?

Thanks!!
Abishek

Hi @srinivasa_abishek,
I’m trying to reproduce the problem, but I couldn’t. Would you mind to share your history with me? My email is Screenshot from 2022-04-03 16-52-09.

Regards

I got the same exact error message, while some time back, I ran the same and didn’t get this message…

Hi @Clem_Lafon,
did you solve the problem?

Regards

Thanks for asking! Yes I did, by removing the last two columns and first row (description) of the Methyldackel output. It then did the trick and Metilene took them with no problem! The weird thing is that I didn’t have this problem at all a year ago when I used the exact same files and process (using it for teaching a course).

Clément

1 Like