MimodD extract variant sites

Hi everyone, I am trying to run MimodD extract variant sites tool with default settings in Galaxy.org and I got the below error for a week ago. I have used this tool many times and it has worked…

Fatal error: Exit code 127 ()
/corral4/main/jobs/051/284/51284803/tool_script.sh: line 10: mimodd: command not found

I first aligned my fastq file using Map with BWA-MEM tool, then ran FilterBAM, MarkDuplicates, CleanSAM, Realign reads, MimodD Variant calling, and then tried to MimodD extract variant sites.

I re-ran it several times, but got same error, tried to run this tool with the data that worked in the past, but got same error now.

Could you help me?
Thank you!

Here is the bug report

Detailed Job Information

Job environment and execution information is available at the job info page.

Job ID 51284803 (bbd44e69cb8906b5ca7ad95501fbcc85)
Tool ID toolshed.g2.bx.psu.edu/repos/wolma/mimodd_main/mimodd_varextract/0.1.9
Tool Version 0.1.9
Job PID or DRM id 42890615
Job Tool Version /corral4/main/jobs/051/284/51284803/tool_script.sh: line 9: mimodd: command not found

Job Execution and Failure Information

Command Line

mimodd varextract ‘/corral4/main/objects/3/a/b/dataset_3ab6f1f4-e4f9-4f97-9ef1-f70de1dbe8c5.dat’ --ofile ‘/corral4/main/objects/6/0/6/dataset_6069d9c4-28b2-40b3-868f-cba502a72c30.dat’ --verbose


/corral4/main/jobs/051/284/51284803/tool_script.sh: line 10: mimodd: command not found


Job Information


Job Traceback


@nate I’ve filed a bug report about this same problem. Can you take a look if you have time?

@sen_99 there is nothing you’ve been doing wrong. It’s a problem with the tool installation on the server.

Thanks for reporting!

Thank you! I was relieved.

As he says, I will try at EU for now.

This should now be working at usegalaxy.org again. Sorry for the trouble, and please let us know if you continue to encounter issues.


@nate Thank you!
I confirmed it works now!

1 Like

A post was split to a new topic: Troubleshooting MiModD