Problem filtering by insert size using Bamtools

bamtools
filter-bam

#1

Dear all,

I attempted to filter a BAM file using Bamtools to select for reads with insert size < 150bp. However the insert size distribution of the post-selection BAM file indicate somewhat a partial selection.

Pre-selection:


Post-selection:

Can anyone advise on how to troubleshoot this?

Thanks.

Anthony


#2

Very odd. What tool version and parameters were used?

I suspect there is a problem in the filter term used. It should be formatted like this (no spaces, no quotes): <=150

Try that and if it doesn’t resolve the problem, click on the job details icon:

job-details

Then post the “Job Information” (first line that reports Galaxy Tool ID: is enough) and the " Tool Parameters" (all) portions back and we can try to help sort out what is going on. Screenshot(s) or copy/paste as quoted text to preserve formatting.

If you know the public Galaxy server URL or the version of Galaxy you are running yourself, that might also help.


#3

Thanks.

Tried <=150 with same result obtained.

And this is the information I got.

On the site it says - Galaxy version 18.09

Galaxy Tool ID: toolshed.g2.bx.psu.edu/repos/devteam/bamtools_filter/bamFilter/2.4.1

Tool Parameters

Input Parameter Value Note for rerun
BAM dataset(s) to filter 90: AL0035-original
Select BAM property to filter on insertSize
Filter on insert size <=150
Would you like to set rules? false

Inheritance Chain

Filter on data 90: Filtered BAM

Job Dependencies

Dependency Dependency Type Version
bamtools conda 2.4.0

Dataset peek

Binary bam alignments file

Thanks again for helping.


#4

Hello,

I was unable to reproduce a filter result like yours at https://usegalaxy.org (same tool version, test dataset).

To further troubleshoot, please either send me a direct message (here) that includes your registered account email at Galaxy Main (https://usegalaxy.org) or send an email from your registered account email address to the private mailing list galaxy-bugs@lists.galaxyproject.org that includes a link to this post. Either way, please leave the datasets involved undeleted so we can review as an admin and try to figure out what may be going wrong.

Thanks!


#5

My login email is <redacted from public site>.

Thanks.

Anthony


#6

Thanks, got it and removed it from the public post. More feedback after review.

Next time you can direct message with private information – go into your message and ask “discobot” to learn how.