problem with "Download and Extract Reads in FASTA/Q format from NCBI SRA” for local galaxy

I just installed galaxy (release_19.05) on a local server (EL7) under the account galaxy and was able to install some tools. But when I tried to download some sequences from NCBI SRA, I got problems. The process got hung. When I checked processes of galaxy, I saw the following two processes.

galaxy    90075  90070  0 19:26 ?        00:00:00 prefetch -X 200G --ascp-path /usr/local/bin/ascp|/usr/local/bin/asperaweb_id_dsa.openssh SRR3541303
galaxy    90076  90075  0 19:26 ?        00:00:00 /usr/local/bin/ascp -i /usr/local/bin/asperaweb_id_dsa.openssh -pQTk1 -l 450m /data/packages/galaxy/database/jobs_directory/000/21/working/sra/SRR3541303.sra.tmp.10369.tmp

When I tried the second process on the commandline, I got prompted for Key passphrase, which I have no idea what it was. When I just pressed enter, I got a “failed to authenticate, exiting.” message. I’ve extensively searched on google and here, but didn’t get any info about such problems. I didn’t see any info about such issues in galaxy document (of course I could have missted it). Any info is appreciaed.

1 Like

I’ve found out the cause and fixed the problem. The private key file /usr/local/bin/asperaweb_id_dsa.openssh didn’t exist. I downloaded the aspera connect from copied the file asperaweb_id_dsa.openssh to /usr/local/bin/.

1 Like