Roary - Fatal error: Exit code 2 ()

Hello,
I have trouble working with roary tool.
I use prokka to annotate my genomes in .gff format (version 3) and then I use Roary with the generated .gff files, to analyse the pangenome.
However it does not work. You will find some screenshoot of the error details.
Thank you for your help,

1 Like

Hi @aperrat

Thanks for providing all the details about the problem. The error was reproducible with independent test data. It is likely a tool installation bug. The tool is newer to the https://usegalaxy.org server. Confirmed tool bug – see updated posts.

We will be fixing this. Details in this ticket. Once resolved, the ticket will close out: https://github.com/galaxyproject/usegalaxy-playbook/issues/293

Meanwhile, the tool does work at Galaxy EU https://usegalaxy.eu, so that is a near-term alternative.

Thanks again for reporting the problem!

1 Like

Hi @jennaj

Thank you very much for your response,
I tried with some prokka files in Galaxy Europe but it failed with my data, with the same error exit code2 (see screenshot).
I don’t understand as my prokka files are in .gff version 3, with Locus tag prefix (–locustag) called P13-1 / P13-2 / P13-3 and P13-4 (screenshot)

Is this the same problem as in galaxy.org?

Thank you for your help!


1 Like

Hi @aperrat

This is the same problem again. And it is not a problem with the tool installation, rather it is an actual tool bug. Thank you again for reporting it!

Evidently there is a bug with the tool when the input datasets contain spaces in the names. The correction should be simple but is still in progress. And it can be avoided without too much trouble at usegalaxy.org or usegalaxy.eu (or anywhere else) until the tool itself is fixed.

This is the original ticket but with more updates, including the workarounds: https://github.com/galaxyproject/usegalaxy-playbook/issues/293#issuecomment-605089574

In short, remove spaces from the input file names. How-to is in the ticket above.

Thanks!

1 Like