Trinity seems to be hanging

Good Morning,
I have been trying to get Trinity running for the last week I have two fastq files that I have been trying to run. One is a raw fastq (no trimming) about 17.5 GB (pre and post Fastq Groomer), one is a trimmed fastq about 15.8 GB (pre and post Fastq Groomer). I am trying to run single strand. I have tried F, R, and Not Set for direction. I have dumped all the data sets that were up previously to free up space. I have tried changing the data type from fastqsanger to fastq. I currently have one post Fastq Groomer file up (15.86 GB) and it is still hanging. Nothing I have tried seems to work.

RNA STAR worked fine, even on the raw data. However, I am trying to do a de novo assembly, so Trinity looks like the only option available. Any insights welcome.

1 Like

Hi @pvos,

A few questions to clarify:

  1. Where are you working? URL if a public Galaxy server. If a different server, please explain the type/source/version of Galaxy and Trinity.
  2. What does “still hanging” mean? Is the dataset gray (waiting to run) or yellow (execution in progress)?
More about fastq data in Galaxy

The datatype will need to be assigned to fastqsanger (uncompressed fastq) or fastqsanger.gz (compressed fastq) for use with Trinity. When a compressed input is selected, a hidden uncompressed version of the data will be created as a preparatory step included in the execution of Trinity.

Also, the tool FastqGroomer does not trim reads. It is used to convert between different quality fastq score scaling. Most data is now already in fastqsanger or fastqsanger.gz format, meaning that a grooming step is not needed. You’ll save more quota space by doing one of these:

  1. allowing Galaxy to autodetect the datatype when using the Upload tool. Compressed fastq data will uncompress, and if the content fits fastqsanger format, that datatype will be assigned.
  2. assigning the datatype fastqsanger.gz when using the Upload tool. This preserves the compressed format. You might want to double-check that your data actually already has Sanger Phred+33 quality score scaling (“fastqsanger”) with the tool FastQC.
  3. re-assign or re-detect the datatype after using Upload if you loaded it with some other assigned datatype already. Most tools that work with fastq data expect the datatype fastqsanger or fastqsanger.gz is assigned. Click on the “pencil” icon per dataset to reach the Edit Attribute forms – datatype is assigned/detected on the “Datatypes” tab.

How-to help for datatypes is below:

I also added in some tags about the different fastq datatypes. Click on any to review similar prior Q&A.

Possibly related: Unicycler launched but still queued after 2 days


If you were working at Galaxy Main, then the jobs were delayed by a server-side issue that was just now corrected.

Please allow queued jobs to remain queued and they will eventually process. This is the fastest way to get the job done. Deleting and restarting will only move your job back to the end of the queue, extending the wait time.

I’m using and it’s gray. Waiting to run

1 Like

Thanks for clarifying.

Many jobs are queued up for the particular cluster used to run assemblies (Trinity, Unicycler) and it is different from other jobs and their target clusters. All will process in the order originally submitted.

Avoid deleting/rerunning or the current job will lose the queue placement – unless you already know there is a problem (inputs or assembly settings) that needs to be changed.

Thanks. I will let it go overnight and see if it starts up.

1 Like