annotateMyIDs (Galaxy Version 3.17.0+galaxy1) not working


I am trying to convert entrez ID from my feature count file (obtained from HISAT2) to ensembl ID.
I am using annotateMyIDs tools. however it systematically failed. I tried to remove the header but still not working. could you help me with that ? THX

1 Like

Hi @francoispot

Please share more details about the error, your data, the server (actually, and the version of Featurecounts you are using. This FAQ covers the type of information we’ll use to diagnose what might be going wrong. A shared history link would include all details by itself or you can copy/paste/screenshot instead. → Troubleshooting Errors

Common reasons for a failure

  1. Incorrect selection of the identifier input type or output type
  2. Genome (“database”) is not supported by the tool, usually because that data is not available from Ensembl
  3. File format or content issues. Needs to be a tabular file with the ID to convert in the first column. The tool form describes with an example, as does this tutorial 2: RNA-seq counts to genes

The latest version of this tool was just updated and seems to have an index problem.

Please navigate to the prior tool version, and use that one instead for now.


We have another reported problem that included an example. The problem seems to be with the index at We are working on it and will post more updates here until fixed.

Thanks for reporting the problem! Next time you have a question, include a link to the error please. That make it easier and faster for confirm/fix actual server side issues. :hammer_and_wrench: