Braker3 - Possible unintended interpolation of @3

I received the following error message from Braker3 when providing a soft-masked NCBI genome assembly. Tried to start braker3 with and without RNA-seq guided bam file, the error message is the same.
Does it indicate a server issue?
Best, version 3.0.7
Possible unintended interpolation of @3 in string at /usr/local/tools/_conda/envs/__braker3@3.0.7/lib/perl5/5.32/core_perl/ line 246.
/data/jwd02f/main/066/992/66992369/ line 27: /gmes/


The error message isn’t specific enough to know, although it does suggest an error from Perl.

Do you want to share more information about your run for troubleshooting?

I also started up a quick test run using the tool test data – get that test data loaded into a history using the Options → Generate tour function (ignore any warnings, let the data load, then start up a test job).

Update: that went quick! I reported the issue with a bug report to the server administrators from that failure.


Hi @jennaj
It seems to be the same error.
FYI: I used a softmasked genome assembly GCF_002217175.1 and STAR mapped RNA-Seq reads as extrinsic evidence.

Hi @jennaj
It seems that the issue has been solved, a run using the tool test data completed without errors.

I started a run with my data, and received an error message. Surprising, the genome file is from NCBI Refseq. Can you see whether the whitespace error is indeed causing this error?
The second error is to my bet knowledge not true. The bam file was created by STAR mapping of RNA-Seq reads to the reference genome.
Below is the warning, and a few header lines of the NCBI fasta file.


# WARNING: Detected whitespace in fasta header of file /data/dnb09/galaxy_db/files/4/1/c/dataset_41cc4805-05b2-4674-bf7c-62813685035c.dat. This may later on cause problems! The pipeline will create a new file without spaces or “|” characters and a file to look up the old and new headers. This message will be suppressed from now on!
# Wed Feb 14 12:31:47 2024: ERROR: in file /opt/BRAKER/scripts/ at line 4662
The hints file is empty. Maybe the genome and the RNA-seq file do not belong together.

NW_019091193.1 Folsomia candida strain VU population unplaced genomic scaffold, ASM221717v1 Fcan01_Sc001, whole genome shotgun sequence
NW_019091194.1 Folsomia candida strain VU population unplaced genomic scaffold, ASM221717v1 Fcan01_Sc002, whole genome shotgun sequence
NW_019091195.1 Folsomia candida strain VU population unplaced genomic scaffold, ASM221717v1 Fcan01_Sc003, whole genome shotgun sequence

Yes, that is likely the problem.

While some tools, and Galaxy itself, will make attempts to reformat data, that is never perfect. It is better to do the data standardization yourself so that you have some control over the process. This FAQ covers the details that matter → FAQ: Extended Help for Differential Expression Analysis Tools

Cleaning up your reference data at the very start has serious benefits :slight_smile: