Cannot drag workflow elements in the workflow editor?

For some reason the workflow editor wont let me reposition elements once they are in a work flow. When I click a box and drag it, it drags the whole screen around, including the whole workflow with it. I am trying to arrange them so I can continue to build out a pipeline… Anyone know what button I pressed to make this happen? And how I can undo it?


Sorry for the trouble – can you test if this happens on any workflow or is it particular to this one? Were you trying anything new with this particular workflow, like the new workflow comments features?

And, what browser are you using? I just double-checked and everything is working as expected for me in chrome and firefox.

I tried in Chrome and it seems to work there, thanks for your suggestion, this will let me keep working!

I was using Edge, and it was originally working. None of my workflows will drag elements in the edge browser version. I dont think I did anything special, just opened the wf editor one day and was just unable to do it anymore.

So I just tried to save the wf I was editing in the Chrome browser, got kicked from the site (force logged out), and when I logged in again I was unable to drag elements. Im not sure if this a bug or something specific to my computer.

Update: I have not been able to fix this yet. None of my workflows (nor new ones that I create) let me drag elements in either chrome or edge. I have now tested on multiple machines and the problem persists.

Since I was initally able to drag on Chrome, i was curious to try a third browser and downloaded firefox. I was able to drag elements (of one of the workflows that I tested on the other two browsers) in this browser.

This behavoir is confusing because the problem persisted accross machines which would suggest to me that it’s a setting in galaxy, but not (initally) across browsers which would suggest a browser configuration issue.

I am going to try and keep editing workflows using firefox, however, I don’t know what caused this problem still and can’t guarantee I won’t accidentally do it again. If it happens in firefox, I may try making a new account altogether to see if this is an account setting issue.

Thanks for the extra debugging here – edge uses the same underlying engine as chrome, so that makes sense. My guess is that if you open the developer console in chrome (打开 Chrome 开发者工具  |  DevTools  |  Chrome for Developers) you may see a relevant error – can you try that? And, can you also confirm this is on, or is it a different server?

I can confirm this is on I unfortunately cannot try the developer console, it seems that my organization does not allow me to open it. (I tried opening it using all three methods in that link you shared)

Thanks for the confirmation. Since it sounds like you’re in a tightly managed environment, I’m wondering how old the chrome/edge versions are – are you able to check that?

There have been some updates to the workflow editor recently and I’m wondering if you have an older browser (since chrome/edge seem to work fine in my testing), or if there are other web apis disabled in your browser (as security policy or something) that are causing this issue.

We’ll get to the bottom of it, though – just have to figure out what exactly is getting blocked here. Thanks for your patience!

Thank you for your help on this!

Edge version is: Version 124.0.2478.80 (Official build) (64-bit)
Chrome version is: Version 124.0.6367.119 (Official Build) (32-bit)