cutadapt Read output not working for RNA STAR

Hello there,

I’ve being trying to use cutadapt Read output as input in a paired-en alignment with RNA STAR. The thing is that some kind of error is happening, and I think I cannot handle it. The STAR output says:

Apr 23 14:04:29 … started STAR run
Apr 23 14:04:29 … loading genome
Apr 23 14:07:30 … processing annotations GTF
Apr 23 14:07:46 … inserting junctions into the genome indices
Apr 23 14:09:50 … started mapping
EXITING because of FATAL

No more information is given.

I’ve tried to run the same alignment using the raw FASTQ files, and setting the same exact parameters as before. Everything worked fine, a in less than 30 minutes STAR finished its job.

So the problem seems to be related with the cuatadapt output. I checked the file format and it says fastq.gz, which seems correct to me. I opened the viewer to see the file, and it looked perfect. The only thing that changed after the trimming process is that I trimmed 5 bp from the 3’ end. Nothing else.

Any idea about what can be happening?

Hi @GuillermoPaz
how you trimmed the reads? PE data should be trimmed only on PE mode, when a tool takes both F and R read for one job.
Run FastQC on trimmed reads. Compare results for F and R. Do the files have identical number of reads? If yes, any other suspicious quality issues? Check read length.
If you used properly paired data, maybe copy files for one file into a new history and shared it here, so people can check what is going on.
Kind regards,