Error mapping short reads with BWA

I am repeatedly getting the error message “Remote job server indicated a problem running or monitoring this job.” when trying to run BWA for mapping short reads against a reference genome. I am using single read fastq data and a reference genome from my history.
The first time I ran the tool it worked on the first read, but none of the rest (4 others). The second time, it worked on none of the 5. Each time I get the same error message.
Is there something I should do differently to avoid this?

Welcome, @katie

That error message can indicate a server problem (transient, and reruns fix it), but also an input content problem. I’m guessing your case is the latter.

What to do:

  1. Confirm that the fasta is useable, see Reference Genome FAQs
  2. Then confirm that any reference annotation incorporated is useable, and a match for the fasta, see Working with GFF GFT GTF2 GFF3 reference annotation
  3. Last, confirm that the read datasets are useable, see Read Quality tutorials

Please give those a try and let us know if you need more help. Where you are working and more details about the exact tool version and your reads/fasta data would be important. So, a shared history link or more screenshots please, see Troubleshooting errors for where/how to find this info. Please leave data undeleted, including the QA tools run, to make reviewing faster for others (FastQC and Fastq info are two good tool choices that check different data attributes).

I ran into the same error since yesterday with bowtie2. I kept trying at different time of the day and the run made it through in the evening, therefore I think it has nothing to do with my input content.

However, I am getting ‘Remote job server indicated a problem running or monitoring this job.’ error since this morning with both bowtie2 and map with bwa-mem. I re-ran the very same job that made it through yesterday but it ran straight to the error. It seems not all tools were affected equal because running Samtools flagstat was fine. Does anyone have any idea on what might have gone wrong?

Hi @itlwong

Please try again now. We had one cluster node that was failing jobs yesterday – and we’ve removed it from the pool.

When you rerun, avoid setting the job resources destination on the tool form, and instead let Galaxy choose the cluster.

Should that still fail now, it would be unexpected. You can post back more details and we can take a closer look here. Same for everyone else. But please try the rerun now first since that should solve most problems faster. See Sharing your History

Thanks for reporting the problem!

Hi @jennaj, thanks for looking into the issue.

I just tried re-running 2 map with bwa-mem jobs and it still runs into the same error. I left the job resource parameters in default (i.e. use default job resource parameters). I’ve just shared history with you by email (

Please let me know if I can provide you with any information you would find helpful. Thanks!

Hi @itlwong I tend to not review direct messages via email. Too confusing and numerous.

I’ll start up a chat here so you can share privately if that’s better for you. Public is always better for us since the Q&A becomes an artifact that can help others – and better for you since more people can help out. But you decide.

Resolved by mapping with BWA-MEM instead.