Error when runnning cutadapt locally vs web

I get the following error when I run cutadapt locally (linux):

An error occurred while running the tool .
Fatal error: Exit code 127 ()
/home/timo/galaxy/galaxy/database/jobs_directory/000/463/ line 10: cutadapt: command not foun

The error only occurs when I run galaxy locally. The same input works in the web application. Other packages (eg fastq-join) work fine locally. So I guess it is a cutadapt specific problem.

Any ideas?


Have you configured conda in your config/galaxy.yml file? I think you need to set:

conda_auto_install: true
conda_auto_init: true

And restart galaxy. And try again to execute cutadapt.

Hey, thanks for your help.

I tried setting these “true” but I still get the same error after restarting.

If I look at Admin > Manage Depndencies, a lot of packages are “unresolved” (see screenshot).

Do I need to install more dependency resolver programs (Dependency Resolvers in Galaxy — Galaxy Project 23.1.dev0 documentation)?


You could now try to remove cutadapt and re-install again. After that try to execute cutadapt or try to install the dependencies from the screen of your screenshot. Then check the log files, if you start galaxy with the command sh --daemon (not sure if this is the standard way of starting galaxy) by default it creates the log file galaxy/galaxy.log. You can maybe also find some info at galaxy/database/gravity/log.

I dont think it is needed but setting conda_debug: true may also help.

1 Like