Extracting reads from fast5 format

Hi Jenna,

I am having the exact same error as posted. I Have an abundance of fast5 Files that return the same result. Was there an eventual solution to this formatting issue? Would be more than happy to share my history if this helps?


Hi @jessemartin

I just reran the two test tools in this history, and both are still functional. Maybe that helps?

Hi Jenna,
I think I am having a similar problem as the original post. I have uploaded fast5 files that have autodetected as “H5” format, however when I run them through both of the tools I get either “1 line or 0 bytes”
I imported the trial data for the tools and that when processed through the tools it works just fine but I cant seem to successfully extra reads from my own files. The original post said there was some formatting issues, could this also be the problem with my data?


Yes, this is likely a problem for you as well if tools cannot read your files.

If the data is compressed, then that compression format should be included on the dataset name.

If Galaxy did not guess the correct datatype (including the compressed versus uncompressed state), then one of these should work:

  1. Upload the data and set the datatype to match
  2. Consider loading uncompressed data to avoid any technical mismatches between the utilities Galaxy uses versus your own computer (or wherever the original source data was created).
  3. Convert to fastq, then Upload the reads to Galaxy for analysis.

Keep in mind that data can be truncated or corrupted when moving it around. This is fatal for a compressed file, and the full original file is what tools will be able to interpret (in Galaxy or otherwise). Utilities from the format developer: GitHub - nanoporetech/ont_fast5_api: Oxford Nanopore Technologies fast5 API software

Troubleshooting the above is what the other person had to do, too.

Once you have reads, then these tutorials can help.