Failed BLAST+ jobs: Tips and formatting help for successful index creation with makeblastdb

Starting last night, we had a series of failures of blastx. These included with two new subject dbs, and with one we had used successfully previously. When we try to run blastx, the message is " Job submission failed" and also “The server could not complete the request. Please contact the Galaxy Team if this error persists. Action requires account activation.”

Is the blast server functioning?

1 Like

Dear tom_abrams_lab,
The tool blastx should run on usegalaxy.eu and usegalaxy.org. Your question misses a bit of context and could involve other problems. First try to re-run your job. If the problems still persist, then please make an error report (click on the bug icon), if you are working in an official Galaxy instance.

Best wishes,
Florian

1 Like

Hi Florian,
I will try to provide more information. This problem appeared on Saturday with a student working with me from another location - she’s at Penn State. We have been using Galaxy since the beginning of April, and as far as I’m aware, neither of us had set up accounts. Uploaded files and histories remain accessible in the browser. When I ran the blastx that she had tried, I got the same error as she did. When I tried to view the error message, it seemed that I needed to be logged in under an account, so I set up an account. I got the error message even for a blastx that we had run before. When I clicked to get more info, I got the full set of blastx parameters, which I would be happy to forward - if I could figure out attachments.
Because the fasta files had been uploaded before the account was set up, and because it seemed that perhaps a problem had developed with these assembly files, I deleted all the files in the history, and then began to upload them. I was unable to complete the uploads and received an error that the account hadn’t been activated. I went to the activation email, and now got an error message that the link was not valid, and that perhaps the account was already active.
I have started the process again by setting up another account on my iPad. I know we are not supposed to use multiple accounts, but this one, which I would prefer to use, is not functional.

I appreciate any guidance you can provide. Thanks much.

Hey tom_abrams_lab,
An error with a tool should not be linked to a problem with your account. If you an active account try to resubmit your job again for blastx. If another error pops up then please bake a bug report. For that, click on the failed job, and then click on the bug-icon. It will then automatically generate an error report for you that can be send to the Galaxy community.

Cheers,
Florian

Hi @tom_abrams_lab

Hi Tom, we talked about this over email but I am posted back the highlights for others that may run into similar problems.

Create an account and log into it to run compute-intensive tools (User > Register). FAQ Registering Accounts

Accounts have an activation step to confirm the registered email address is valid and belongs to you. Activation links are sent via email and are active for about six hours. Resend if needed using the password reset function (User > Login).

As you noticed, activation emails can be sorted into Spam or Trash folders depending on email filters, so if others run into the same problem check in those locations or search your email account with the keyword “galaxy” if it seems to be missing.

If you never get an activation email (can take a few hours to arrive, depending on how busy the server is), your email service may be rejecting the email. We’ve seen more of this occurring with institutional email services over the last year as updated security was implemented. Contact your institution’s administrators to request that emails from the @lists.galaxyproject.org and @galaxyproject.org domains are accepted. Or, use a public email service instead. Please delete any accounts that will no longer be used (User > Preferences) to avoid multiple account issues. Account quotas at most public Galaxy servers are one account per person per public Galaxy server. Meaning, it is fine to have a single account at each but you shouldn’t have more than one at any particular server. FAQ Registering Accounts


More help about using custom fasta datasets indexed with makeblastdb

Formatting of the fasta dataset matters. The usual custom genome format rules apply Datatypes, plus BLAST has more options for parsing line/identifier content than other mapping tools

  1. Problems with format usually do not show up until the database index created from the original fasta is mapped against. Meaning, the job output from makeblastdb may appear to be successful (green), but the index is corrupted, and running blastn, blastx, etc will fail when mapping against that index. The stderr will report that the index cannot be found. The error will start with text like this and means that you need to correct the fasta format and rebuild the index.

    stderr

    BLAST Database error: No alias or index file found for … (more details specific to your data)

  2. Remove description line content. Tool: NormalizeFasta using the option to “remove content after the first whitespace”. Wrap the sequence length to a value between 40-80 bases for the best results with most tools, including BLAST.

  3. The fasta identifiers can include alphanumeric characters (a-z, A-Z, 0-9), underscores (_), dots (.), and dashes (-). If you want to keep the description content, replace other characters with one of those. The goal is to produce sequence identifiers that are all one “word” with no whitespace (tabs, spaces) or other characters that BLAST cannot parse. Avoid very long identifiers (over ~30 characters), or expect problems.

    Search the tool panel with the “replace” keyword to find all tool options. Replace Text in entire line should work with most data.

    Alternatively, a tool like Text transformation with sed can also be used within Galaxy. For example, a command like this will replace all commas with a dash in the entire file.

    s/,/-/g

  4. Pipes (|) can be Ok, but the fasta data containing these characters are best sourced from NCBI and the option Parse the sequence identifiers should be used with the makeblastdb tool when creating the database index to map against.

    … other options, then find this option and set it to "Yes:


Thanks for reporting the error, glad this is working for you now, and hope these tips help others :slight_smile: