Failed local file upload with 504 timeout: Resolved at March 31 2023

I’m unable to upload simple small (400 bytes) test file (fasta).
The spinner keeps spinning and nothing gets uploaded.
I’m getting 504 gateway time-out error from “/api/upload/resumable_upload/”. The method works on “”. I’ve tried different browsers and internet providers, I’ve also tried to switch autodetect and fasta format, but with no success.
Is there anything I can do on my end (pasting file content is no-go for me, as actual files are much larger).

Thank you

I have encountered the same issue in the “” server. Nothing uploads. Even small fasta files.

Hi @marek and @osman.merdan

The server had a maintenance event earlier but seems to be up now. Maybe try again?

Chat: You're invited to talk on Matrix

I don’t use galaxy often and it seems it was bad luck.

However, the upload still does not work for me. This time, it reports different error (502)

[HTTP/1.1 502 Bad Gateway 13ms]

Failed because: Error: tus: unexpected response while creating upload, originated from request (method: POST, url: /api/upload/resumable_upload/, response code: 502, response text: <!DOCTYPE html>

      <title>Galaxy Europe, error page</title>
      <link rel="canonical" href="">
     <iframe src="" style="position:fixed; top:0; left:0; bottom:0; right:0; width:100%; height:100%; border:none; margin:0; padding:0; overflow:hidden; z-index:999999;">
        <a href="">502</a>
, request id: n/a)
, will retry in 10 seconds

Hi, same problem here with some BED files. From yesterday, nothing can be uploaded in Galaxy.

As of now, the upload works.

1 Like