upload from FTP gives: bad request (400)

hi there, I uploaded to usegalaxy.org some fasta files with mozilla, but when I click to start the import of those file in the ‘choose FTP file’ I get a warning: bad request (400) error. tried to reupload those files with filezilla but still the same error. can someone help me?

1 Like

I can confirm this is broken, probably due to today’s update of Galaxy. I believe we will fix it tomorrow. Sorry for the inconvenience.

1 Like

This looks to be fixed now to me, just uploaded a file. Please give it a try now.

Update: We are still having a bit of trouble.

Please see our gitter chat post for details now, and how to check for updates ongoing: https://gitter.im/galaxyproject/Lobby?at=5d83aca2e45b6d47321e5164

But if anything is unclear, can always ask here.

I am having this same problem. I uploaded 16 files of the same set a week earlier and now I get the 400 error when I try uploading the last 8 files.

1 Like

Hi @Kuksi – if you are working at UseGalaxy.org, the server is being upgraded to the 20.05 pre-release for testing today. Please try again now.

I’ll also run a quick test and will post back with the result, and check whether this is a known issue or not being addressed (pending or done).

More feedback after the checks. Thanks for reporting the issue!

Great! Thanks. Will try in a bit when I get to my computer next.

1 Like


Great, please do.

I just tested FTP and things are working. Yours probably will too. But if this happens again over the next week or so, wait a bit (5-10 minutes) then try a rerun. The release testing involves restarting the server a few times, which can impact this particular function (external data upload). If the function seems to be down for longer time span, please write back if you have time. Things can be broken while others get fixed :sweat_smile:

Ok. Thanks. Just tried twice and I am still getting the same error. Will keep testing every 15 minutes or so and will let you know how it goes.

Just to specify what I am doing: 1) I upload my fq.gz files to the ftp server using file-zilla. That step executes without problem and it is very fast. 2) I click on the upload data button (usegalaxy.org) and when the dialog appears I click on choose FTP files. All my files are there. 3) I click on select all then I click on start. 4) I immediately get a 400 error.

I also tried uploading two files just by drag and drop into the upload area. The first file uploaded (surprisingly fast), but the second file did not even start until I canceled about an hour later.

1 Like

Update 4/21/2021

FTP Upload has been corrected at UseGalaxy.org

Thanks again for reporting the problem!

Hi @Kuksi – Ok, I can confirm the problem. A few files will load, others fail for the same reason as you report.

This is likely related to the reconfiguration going on right now but I’ll confirm that with the dev team.

An immediate solution would be to use a different public Galaxy server right now if your work is urgent.

1 Like

Thank you for helping with this. I will try galaxy.eu and will let you know if that works.

1 Like