Failed to proceed with featureCounts

Hi all,

I am currently doing RNA-seq analysis for tomato. I have managed to map my trimmed reads using both RNA STAR and HISAT2. However, I have failed to get past featureCounts because it’s return an error every time I try. I have also tried mapping with two different reference genomes (Index of /genomes/all/GCF/000/188/115/GCF_000188115.2_SL2.40 and Index of /ftp/tomato_genome/Heinz1706/annotation/ITAG2.3_release/) but all in vain. Could I be getting the reference genome files wrong? Or what could be the problem with my analysis?
Kindly help.

Hi @oscar.mitalo,
could you share your Galaxy history with me? My email is Screenshot from 2022-04-03 16-52-09.

1 Like

Hello @gallardoalba, I am afraid I erased all the history and then started afresh.
I will share the new history in the case I encounter the same problem again.
Thank you

Hello @gallardoalba I have shared my history with you. Got the same error like before.

Hi @oscar.mitalo,
this is the problem:

In order to fix it you can use the tool Text transformation with the following expression: s/Parent/parent/g on the GFF file. Then you should use the new file as input for FeatureCounts.


Hello @gallardoalba Thanks for your quick response.
I identified what the problem is: wrote parent instead of Parent.
I have managed to run featureCounts successfully but there is a new problem.
The analysis does not generate any read counts.
Could you possibly know why this is so?