galaxy-upload keyerror: update_time

I am trying to upload data to galaxy using galaxy-upload.
but I always get the same error message:

Traceback (most recent call last):
File “/group/yield/Users/jupev/.conda/envs/galaxy2/bin/galaxy-history-search”, line 8, in
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/click/”, line 1157, in call
return self.main(*args, **kwargs)
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/click/”, line 1078, in main
rv = self.invoke(ctx)
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/click/”, line 1434, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/click/”, line 783, in invoke
return __callback(*args, **kwargs)
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/galaxy_upload/”, line 84, in main
table = make_table(quiet, histories=histories)
File “/group/yield/Users/jupev/.conda/envs/galaxy2/lib/python3.11/site-packages/galaxy_upload/”, line 30, in make_table

KeyError: 'update_time'

I have tried with docker, a local installation in the base environment and an anaconda environment, both from my personal computer and via my works linux server. It is always the same error message **KeyError: 'update_time'**
Does anybody have an idea what is going wrong?

Kind regards,

Hi @Juliepvr

Few questions first to get oriented:

  1. Which server are you trying to Upload data to? The base URL please.
  2. What version of Galaxy is that server running?
  3. What does the command string look like?
  4. Anything else about the Galaxy server configuration that you think would be relevant.

Let’s start there :slight_smile:

Reference: galaxy-upload — galaxy-upload 1.0.1 documentation

1 Like

Hi Jenna,

I just found out is an older version (21.01), when I tried to use galaxy-upload with I didn’t encounter any problems


1 Like