Issue with history file export

I am getting the following message when I try to export my history. Is it that the page is down (status page is reporting no issues currently) or is the link broken?

The webpage at might be temporarily down or it may have moved permanently to a new web address.

Can you please verify that the issue is still occurring? I’m looking into this but can’t reproduce the error so far. Thanks!

I just checked and it is still happening. When I click the export tab it gives me the link immediately. Previously, it would take up to 20 mins sometimes for the data to be compressed and a link generated. I am using Chrome as my browser if that helps.

Can someone let me know if there is a fix for this issue? It is still happening.

Sorry for delay! Does this happen on any history or only one particular history? i.e., if you create a new history, run a simple job and then try to export it - does the same error happen?
Also, I assume the message you get appears instead of the expected “History ready… use this link to download…”? (see screenshot)

EDIT: the URL included in the message you see does not include anything after ?id=, right?

Hello. I get that first link in the screenshot when I try it with any of my histories and then it gives me the message below.

The webpage at might be temporarily down or it may have moved permanently to a new web address.

I removed the actual ID for privacy while posting. It does show up on the error message.

Thanks for the fast reply! Looking into it now. Is your username on same as here?

and another question: was the history and included objects (datasets) shared before generating the history archive?

Sorry just seeing this. Yes the username is the same and I did not share the history before trying to archive.

This may or may not work… Try to make your history accessible first, then rerun the export to file. Here’s the link: (it’s the “share or publish” option in the “history actions” menu.

Thank you for the suggestion. It does work if I follow your instructions. Do you know if this is the new procedure to generate archives or is this a temporary fix for my issue? Just wondering. Again thank very much delving into this and finding me a solution. I really appreciate it.

Great! Glad this fixed it. It’s not a temporary procedure - it’s the expected way to handle exports. However, what you had was most definitely a bug we need to fix. When I tried to replicate your error, I was able to generate the archive; also, a message was displayed telling me that I would need to make the history available - which is the expected behavior. In your case, a server error occurred instead. It may have been something transient, but we’ll be looking into it regardless. Please let us know if this reoccurs.

Thanks again! I will definitely use this procedure going forward. Please stay safe!