Porechop tool not working

Hi, I have been working through the 16S microbial analysis for nanopore tutorial prior to loading my own samples, and I cannot get the porechop tool to work. It has been a few years, have the tools changed in regards to removing the adapters for Oxford nanopore?

Welcome, @jemimahair

These are the things that can change over time, or between tool runs in general:

  1. The tool version. If you have your prior run, you can check to see what version you were using before, and switch to that same version now for an exact rerun FAQ: Changing the tool version. And, if you were using a workflow, that original tool version will still be a part of your workflow unless you specifically updated it.

  2. The tool parameters. This can make a big difference in how a tool runs. A workflow would save this exactly, the same as the tool version.

  3. The input data. This can also make a huge difference in how a tools runs, of course.

  4. The Galaxy release. This shouldn’t make a difference in how a tool runs scientifically.

  5. The Galaxy server. This might make a difference but mostly with respect to the items above. The rest is more related to the server cluster resources e.g. can the work be processed where you are working (enough memory, or runtime limits)

Is the tutorial failing when using the tutorial data? I would be curious about this. Which server? And which exact tutorial (URL please to confirm we are looking at the same thing)? Does it fail when using the tutorial workflow, too? We could get this fixed.

Or does it work on the tutorial data but not your own data? This either means the data has a content problem, or wasn’t fully uploaded, or the parameters need to be tuned. … or something similar to this.

Let’s start there, thanks! :slight_smile:


I managed to get it working in the end! Sometimes it wasn’t appearing when I searched for it in the tools search bar and other times it did appear, so I am not sure what I was doing wrong there. The second time I ran the workflow for the tutorial it worked, however the first time it was stuck on the pore chop command for a very long time (12 hrs), so it may have been an internet issue on my end. The tutorial I used was this one: Hands-on: 16S Microbial Analysis with mothur (extended) / Microbiome (galaxyproject.org)
and I found the workflow in public workflows.

1 Like

Hi @jemimahair

Great that you got this working! And yes, any tool might queue if the server is busy or you are running a bunch of jobs at the same time. Let those grey queued jobs process since any new reruns would also queue, but starting back at the end again! More details about how jobs process are in that Troubleshooting FAQ above.