Problem with Uniclycler

I have tried to assemble paired reads (Illumina) with nanopore reads but I always obtain the same error:

An error occurred with this dataset:

format fasta database [?]
cannot find ‘lr’

Could anyone help me with this?
Thanks in advance

Hi @mlopezm,
the dataset W1550.R1.fastq.gz seems to be truncated. I suggest you check the original files in order to confirm that both the forward and reverse datasets have similar sizes (differences usually indicates truncated datasets).

Regards

Thanks @gallardoalba ,
However, I have tried with another fasta files and I still obtain always the same error. I also tried with the fastaq (isteas of .fq.gz) and stiil the same error:

An error occurred with this dataset:

formato gfa1 base de datos ?

cannot find ‘lr’

and:

An error occurred with this dataset:

formato fasta base de datos ?

cannot find ‘lr’

I would appreciate any help with this,
Regards!

Hi @mlopezm – someone else had a problem with Unicycler recently, and while the problem was slightly different (reads were in a collection), simplifying the data labels fixed the issues. Maybe give it a try?

Specifically, remove any dot characters. Underscores/dashes are fine.

myfile.fq.gz -> myfile

myfile.fastq -> myfile

myfile_R1.fq.gz -> myfile_R1
myfile_R2.fq.gz -> myfile_R2

Disclaimer :construction: May not work but worth a try.

Thanks @jennaj ,
I have tried simplifying the names, but still the same problem… I tried with the dataset of the tutorial and it works.

Hi @mlopezm,
as I mentioned to you by email, please try to reproduce the error in usegalaxy.eu and share the history with me.

Regards

Dear Cristobal,

First of all, I am very grateful for your help. After been trying different options (I even tried to assemble the reads that were included in the tutorial and it works), I thought that the problem was in my fastaq.gz files. Another person suggested simplifying the name, but this did not work either. Finally, after reading this tutorial: https://www.melbournebioinformatics.org.au/tutorials/tutorials/hybrid_assembly/nanopore_assembly/, it was indicated that:

Select long reads - nanopore_reads.fastq
(if nanopore_reads.fastq does not appear in the dropdown, its datatype needs to be changed - click then pencil icon next to nanopore_reads.fastq in the history panel → ‘Datatypes’ tab → ‘New Type’ - fastqsanger)

I tried this, and, at least, it is processing (other times it failed in the first minutes), so I think this could be the answer.

Nevertheless, I´ll keep you posted about the result of the assembly.

Thanks again,

Regards

María

2 Likes