RNA STAR not allowing genome index choice

The current version of RNA STAR is not allowing the choice of a genome index. I tried to use an older version, and in fact these allow the use of the indexes but, we get an error as soon as the job starts to run. Any information on that?

1 Like

Hello @Ana_Maria_Abrantes

Apologies for the delayed reply.

The most current version of RNA STAR requires new indexes due to some technical changes. Those are not quite ready to be created and deployed at usegalaxy.org.

Older versions were failing last week due to changes made to the clusters at usegalaxy.org. The technical reasons are now cleared up but jobs may still fail due to current resource allocations.


  • usegalaxy.org: RNA STAR Gapped-read mapper for RNA-seq data (Galaxy Version 2.6.0b-1). Note that all versions of this tool are currently running with reduced memory allocation at this server. The server has a banner explaining which tools are impacted.
  • usegalaxy.eu: RNA STAR Gapped-read mapper for RNA-seq data (Galaxy Version 2.7.2b). This version of the tool has limited genomes, but you can review older versions to see which may already have your genome indexed.
  • usegalaxy.org.au: RNA STAR Gapped-read mapper for RNA-seq data (Galaxy Version 2.6.0b-2). A different set of limited genomes. Version 2.5.2b at this server is also still pending indexes.
  • At most public Galaxy servers, you can load the fasta of your genome to the server and use it as a custom genome. Note that this will not work well for large genomes (tools will fail for memory reasons).
  • HISAT2 is an alternative spliced mapping tool for RNA-seq data and has smaller memory requirements.