RNA STAR Reference Genome at UseGalaxy.org -- Resolved

When using RNA STAR in the past, I’ve been able to select from many built-in genomes as a reference. However, under the “select reference genome” I only see “No options available.” This occurs if I select with or without a built-in gene model. If anyone can give me any tips on how to find a way to select a reference genome (I only need mm10 and hg38) it would be much appreciated!

1 Like

Hello @hwalter684

We were able to confirm the issue.

A ticket to get this resolved has been created and can be found here: https://github.com/galaxyproject/usegalaxy-playbook/issues/292

A test to see if an earlier version of the tool will work is in progress. You could also test it out. Using usegalaxy.eu instead is another short-term option.

The ticket above has the details for everything mentioned. The ticket will update as more workarounds are confirmed and/or the tool itself is reconfigured to locate the indexes properly.

Thanks for reporting the problem!

1 Like

This problem still remains or has it been fixed?

I am trying the same problem these days.

1 Like

Hi @Vanessa_Souza

Yes, the tool is still problematic at usegalaxy.org.

At usegalaxy.org, the version with indexes to use is 2.6.0b-1 – and that worked for smaller runs for about 3 weeks (the tool has reduced memory allocation, as noted on the server’s banner).

We have been making changes to the configuration this week to again run with higher memory and that is not yet completed. Jobs may startup, but then stay in the execute state indefinitely. Unless you happen to hit the window when it is actually fixed! No estimate for that yet but we are trying for “very soon”.

If you really need to use STAR (HISAT2 is not an option for you), using usegalaxy.eu is an option. There are fewer indexed references genomes for the most current tool version than for earlier tool versions, but mm10 and hg38 are indexed (last time I checked). Using a custom genome is a choice, but only for very small genomes. STAR is a memory-intensive tool.

Using usegalaxy.org.au will present with the same issues as usegalaxy.org for the reference genomes (re: none for the most current tool version). I haven’t tested earlier versions that do have indexes at that server but I am also not aware of any issues.

The cluster set-up is (mostly) different between all usegalaxy.* servers – so if there are issues at usegalaxy.eu or usegalaxy.org.au those would be due to a different reason than what is impacting usegalaxy.org right now.

In summary, two primary factors:

  1. The latest tool version requires newly rebuilt indexes (everywhere). Those are not all completed nor synched between all usegalaxy.* servers yet.
  2. Server configuration is undergoing changes at usegalaxy.org. The impacted tools are in the top banner.

Thank you for your patience and for asking for a public update!

This still appears to be an issue. This time for the mouse reference genome:
slurmstepd: error: couldn’t chdir to `/srv/pulsar/main/venv/lib/python3.6/site-packages’: No such file or directory: going to /tmp instead

EXITING because of FATAL ERROR: could not open genome file /cvmfs/data.galaxyproject.org/managed/rnastar/2.7.4a/mm10/mm10/dataset_76d29985-2936-4202-8fba-6658b0e3499e_files//genomeParameters.txt
SOLUTION: check that the path to genome files, specified in --genomeDir is correct and the files are present, and have user read permsissions

Sep 17 19:45:11 … FATAL ERROR, exiting
[E::hts_open_format] Failed to open file “/jetstream/scratch0/main/jobs/30670709/outputs/dataset_45225756.dat” : No such file or directory
[E::hts_open_format] Failed to open file “/jetstream/scratch0/main/jobs/30670709/outputs/dataset_45225756.dat” : No such file or directory
[E::hts_open_format] Failed to open file “/jetstream/scratch0/main/jobs/30670709/outputs/dataset_45225757.dat” : No such file or directory

1 Like

The issues with RNA-Star should be resolved now. Please try a rerun if you have not already.

Hi, I have a somewhat related question. Rather than using the public galaxy servers I am using a local instance of Galaxy (20.09) with RNA STAR (Version 2.7.6a) that also does not populate the reference genome tab with any species (I’m only interested in human right now). I have tried 2.6.0b-1 and other lower versions as well but none populate this dropdown. Now that I read your thread I’m wondering if I need to create and upload the index files myself. And if so how do I do this? I couldn’t find documentation on this.

p.s. related to this I noticed that string tie also does not show a reference genomes maybe the issues are related. Any guidance on these items would be greatly appreciated.

1 Like


Maybe you discovered this already, but you will need to install reference genomes and their indexes in your local.

This is one prior Q&A that may help – and includes links to others. Or, you can search the forum with the keywords “data manager” for more.