Troublshooting Unique.seqs: Status: resolved, please rerun prior failures

I am running into problems with the Unique.seq tool in Galaxy. I use Galaxy online to teach a course and we use the 16S Metagenomics (Mouse) dataset as the training module. I have been using this approach for a couple of years now, but we have run into a Fatal Error when running the first step of the Unique.seq tool. We have tried to run Unique.seqs from multiple accounts (students and mine), but always using Galaxy online. I have tried it from our computers at work (faster internet) and from home. Again, over 400 students in the class have done this over the years and we have not encountered the problem until now. Any suggestions? Belwo is the error messages we get from Unique.seq. There is an error for each of the three output files from Unique.seqs.

An error occurred with this dataset:

format mothur.names database ?


1 Like

Hi @Ouverney

Please send in a bug report from one of the errors, leaving all inputs and outputs undeleted and we can try to help. Please also share the workflow you are using, and shared history link where the same was done successfully before if at all possible – both links can go into the comments of the bug report. If you didn’t generate the log for the failed run, please run one more time after checking that box and leave it also undeleted in that same history.

Another person reported a similar problem, and this was the solution. Maybe check to see if that helps first?

  • The tool is expecting another input, the second on the form, the label is: “name file or count table”.
  • The output from Screen.seqs can be used.

The final option is to try using a workflow from the tutorials. You can adjust parameters to match your data and check for differences between your workflow and tutorial’s most current workflow.


Here is the history in the USA Galaxy where the problem with Unique.seq happened:


Just today I ran the same set of data (the Galaxy mouse tutorial for 16S metagenomics) in the Australian Galaxy and Unique.seqs worked.

And here is the History for that test in the Australian Galaxy:

I will check the suggestions you listed in your email once I get a break. Thanks for any help you can provide.

I appreciate it.

1 Like

Great, thanks for sharing the links.

  • The version of the tool used at the AU server is:
  • The version of the tool used at the ORG server is:, but the updated version is also available. Would you please retry using it?
  • If you are incorporating a workflow, maybe that needs to be updated, too? The older version of any of these Mothur tools might have technical problems or otherwise not work well together with mixed versions (some had known bugs, others were replaced with updates re dependencies). The most current of each is the best choice.

Thanks. I will try the ORG server once I get a chance.

Yes, I am teaching a class that was created during the pandemic (summer 2020).

I noticed there is an “extended” version of that module.

If I understand you correctly, I should update my course to include the updates from this new extended version?

Updates are routinely applied at the training site. See the “last updated” information at the top of every tutorial. For these two, only the extended version has had changes applied since 2020.

Update April, 2023

The tool has been adjusted. Please rerun prior technical failures.

Thanks to everyone who reported the issue, and to all that helped fix it :partying_face:


The Unique.seqs tool has a bug at (only).

Details are here Mothur Unique.seqs -- fails when an optional input is not provided at ORG · Issue #5163 · galaxyproject/tools-iuc · GitHub

The choices are to use instead, or to supply the optional input until the fix is live on the other server.

Thanks for reporting the problem!