zero scores for rrnS and rrnL genes in MITOS2

Does anyone know why the scores I get for all rrnS and rrnL genes are zero in MITOS2, is this expected output?

Hi @BShelb

We can’t help with interpreting scientific results here (a scientific forum would be a better choice) … but for just this part: do you mean the BLAST score? This just means that the aligned region involved has an equal number of matches and mismatches – for just that aligned region. It could be really short, or longer and just parts are mismatching. At the nucleotide level, you’ll have to decide how meaningful that is for your purposes.

Maybe print out more of the optional outputs? Then, try to visualize the regions to see if you can get more insight into what is going on. That might help you to adjust parameters and make other decisions.

Likely not sure helpful, and others are welcome to add more… but I still think this isn’t the right place to get the best feedback. Try to find the places where others using this tool or working in this analysis domain are spending time online :slight_smile:

Thanks, I will try somewhere else.

I thought the online version of MITOS was hosted on galaxy, and I didn’t think asking about unexpected outputs from the tool was a scientific question.

I’ve simplified the question in case that helps.

Hi @BShelb

Maybe I misunderstood. I thought you were asking about how to improve the results (scientifically). If instead, you think that the tool is not outputting the correct result, and that might be some tool bug or input mixup, you are still welcome to share your results and we’ll review here and try to help more. :slight_smile:

How to is in the banner at this forum, also here: How to get faster help with your question

Thanks, I should have prepared an example to share.

When I run it again on a curated mitochondrial chromosome then the scores for these genes are zero again. Although strange, it seems to be the usual output.

1 Like

Hi @BShelb

I’m not clear on which score is zero … but I did start up a test run to make sure the tool was working as expected. Maybe this example history will help, too?

See → https://usegalaxy.eu/u/jenj/h/test-mitos

The primary BED output has content (a statistic in the “score” 5th column).

  • Tools: both MITOS and MITOS2

  • Inputs/parameters: I used all defaults with a super small test file for the first run’s output, then I ran it again and chose to output all of the possible results.

  • Results: The “score” field in the BED is the eValue from BLASTN. That value works a bit differently than a BLASTN score value. For eValue, “smaller is better” (more significant**). If the value is too small to write out, then it gets rounded off by BLAST itself. For this case, it flows out to the output from MITOS/2.

    • **There is a lot of discussion online about how to interpret a BLAST eValue… too much to write out here. Try a search with “blast evalue 0.0” for more about this.

All of it seems fine to me but let us know if you have questions. :slight_smile:

1 Like

Thank you for looking further, a low e-value would make sense for these genes.

I couldn’t find anything to explain what was printed in the score column, maybe this can be added to the help section. There is discussion of a ‘quality score’ in the help and that makes it even more confusing.

1 Like