Error message in plant dataset


I am running fgsea on a plant dataset but I get this error, cut and pasted below. What does the error mean and how do I resolve it? Does it imply that I have something unreadable in one of my input files itself (i.e. my plant ontology file)?

Thanks in advance for insights or experiences.

Warning message:
In Sys.setlocale(“LC_MESSAGES”, “en_US.UTF-8”) :
OS reports request to set locale to “en_US.UTF-8” cannot be honored
Error in scan(file = file, what = what, sep = sep, quote = quote, dec = dec, :
scan() expected ‘a real’, got ‘PHT2’
Calls: read.table → scan

Hi @jclaudio

Yes. This is an R error from the underlying tool. The tool was expecting a type of data that it didn’t find in the file where it looks for that specific data. The file itself could have a different datatype/format or the format is fine but has content problems.

The first two listed here are the Galaxy tutorials that incorporate the tool. The data and parameter examples can be useful even when not following a tutorial. In particular, notice the steps to preprocess the input: only certain data columns are included and those lines are sorted to create a “ranked gene list”. Search Tutorials

Other resources include the help forum for the underlying tool hosted by the original authors. Using the tool directly involves more steps but most parameters are available on the Galaxy tool form. Bioconductor Forum

If you would like more help, please share more details. This is the information that is most helpful. If you decide not to share the history, at least share screenshots of the expanded input datasets and the contents of the Job information view that include parameters (same place where job logs are). Troubleshooting errors

Thank you for your response! Here is the history: Galaxy

I am using a gene ontology file downloaded from TAIR, and thus far I’ve tried comparing its parameters and formatting to ones for other organisms that have worked when I tried them out. I also updated the data type during the upload. (Thank you for your reply to a previous post of mine that helped me do that!)

I will go back and check some of the parameters described in the tutorial, then I’ll look into the ontology file to see if there’s some kind of tags that the tool does not like. Thank you again for your support!

1 Like