Goseq: incorrect number of dimensions

Dear All
I am getting this error on the Goseq Galaxy
Using manually entered categories.
Error in [.default(summary(map), , 1) : incorrect number of dimensions
Calls: run_goseq … goseq → reversemapping → [ → [.table → NextMethod.
I am new and have no idea how to solve this error. please help!
Thanks in advance

1 Like

Hello @rizwan_rehman_rehimi

Your error suggests that the data file doesn’t match the parameters or the assigned datatype (“format”).

What to do

  1. Scroll down on the tool form, and review the examples versus your own file (click on the “eye” icon to see the text in the middle panel). Can you notice a difference? Maybe a “space” was included in a column header/sample name label? Tools prefer labels that are all oneWord, and can present with errors like you have when spaces are included.

  2. Keep scrolling down to find the GTN Tutorials that include this tool. Those will have example data, along with a workflow. Try running the workflow on that sample data, and examine the inputs/outputs where this tool was run for another data example for expected format.

  3. Review prior Q&A here at this forum to see if any of those examples are also your use case. I’ve added the tool name tag to your post, but also see goseq

Please give those two a review and you’ll probably solve the problem. But if you get stuck, you can share your work for more feedback. A shared history is probably needed since you already shared the tool error and it wasn’t enough to resolve this with specificity yet. How to:

Let’s start there! And if you figure this out, a reply would be appreciated to help the next person who has this same error. :slight_smile:

Thanks for your help.
However, I am still not successful in solving the problem. I only get column numbers in my change case file but not headers like GENEID and DE_STATUS. Maybe that’s why not working. Should I share my history?

Hi @rizwan_rehman_rehimi

These files do not need headers. Both are just two columns.

These are quotes from the top of the tool form.

  1. First file: GeneID in the first column, true/false in the second column

    • A tabular file with GeneID in the first column, and True or False in the second column. True means a gene is differentially expressed. See Help section for details.
  2. Second file: GeneID in the first column, a number in the second column.

    • You can calculate the gene lengths using featureCounts or the Gene length and GC content tool.

It is hard to guess exactly what is going on without seeing the data your exact data and how you set up the tool form, so please share your work if you want to for more feedback and I’ll try to help more. We like details! :hammer_and_wrench: :scientist:

I think I have a decimal in my GeneID. that could be the problem how can I remove the decimal from gene ID?

Hi @rizwan_rehman_rehimi

You could technically replace it with an underscore … but that would impact how the later matches are made with the tool (what you select for the Select Gene ID format option).

What you could do instead is go out to the public source where you making the connection and review how the GeneIDs are formatted, then use that same annotation scheme for your own analysis.

And, also check the columns in your data – are you sure that each file has only two? You are still welcome to share your history. It is difficult to guess what might be going wrong without seeing the data.