problem with scanpy: The tool "Normalization with scanpy" seems not work!

hallo, galaxy users,

thanks for fixing the problem I showed here last time. Now I am continuing to follow the training "Clustering 3K PBMCs " by Bérénice Batut et al. I was stopped this time at the step “normalize with Scanpy”. Every time I got the message “An error occurred with this dataset:
This job was resubmitted to the queue because it encountered a tool detected error condition on its compute resource. File “/data/dnb03/galaxy_db/job_working_directory/015/987/15987443/configs/tmp943xjhku”, line 18
layers[str(x.strip()) for x in str(A.” I tried different versions available in the galaxy, and it came out similar error texts.

I checked the files produced before this step and all of my operations again and again, and have no idea what was wrong with the tool.

Hello, which server are you using?

use, or

Dear Mr. Neiman,

Thanks so much for your quick feedback. I am using Galaxy europe for carrying out this job. But I have also an account at Galaxy usa.


Hongyu Liu


Can you share your history with me – I am unable to reproduce this problem.
My email for sharing is:

hallo, dear Dr. mtekmann, thank you very much for your help. you can try the linke here under to get acess to my history. I tried at first to follow the tutorial to do the data processing with Star solo and RaceldD. Since the down streaming analysis with RacelD did not work, I uploaded the datasets from the tutorial “Clustering 3K PBMC data with scanpy” and learn scanpy step by step.

Galaxy | Europe (

thanks again.

Hongyu Liu

here the link to my history:

Hongyu LIu

Hello again,

Can you repeat the step, but this time remove the keyword All from the “List of layers to normalize”. It should still work without it

thanks so much! It works after I deleted “All”.

1 Like