Still need to remove @ from paths in perl script?

I ended up with this error message after using Maker in the Main Galaxy instance: “Possible unintended interpolation of @2 in string …”. My attempts to autodetect the metadata to correct the problem did not work.

I saw that others had this error with other tools (e.g. Trinity) within the last couple years. In one case, @jennaj said the error meant insufficient memory was allotted to the job or that the inputs were wrong. Hoping this was the case, I checked the input and ran the job again, but got the same result.

In another case, Matthias Bernt said it was a miscommunication between Galaxy, which uses the “@” symbol, and the perl interpreter that doesn’t know what to do with it. He suggested adding a " \ " in front of the “@”, although I don’t know how to access the script to do this.

Any other ideas on how to handle this type of error? I still can’t tell whether it’s possible to salvage my results, which were apparently successfully run aside from the metadata problem that couldn’t be resolved. Or should I simply keep rerunning the job until it works?

I got this error while doing the genome annotation tutorial, but I want to know how to avoid this issue when I’m using my data.

Thanks!

Can you post the full error massage, please?

Thanks, @David. Here’s my error message:

Possible unintended interpolation of @2 in string at /cvmfs/main.galaxyproject.org/deps/_conda/envs/__maker@2.31.11/bin/…/lib/5.26.2/x86_64-linux-thread-multi/Config_heavy.pl line 260.
Possible precedence issue with control flow operator at /cvmfs/main.

But others have had similar messages, for instance here and here.

I don’t see this specific issue among the known issues in Galaxy Main (although maybe I missed it). What’s the best way to proceed when confronted with this? Obviously it doesn’t always happen when people use Maker, Trinity, etc., but if there’s a way to go into the script to bypass the “@” problem, I’d like to know.

Hi,
AFAIK, the only way to correct this is going to the actual code, as it seems is hard-wired. The Galaxy team should take a more detailed look.

There are at least 4 other issues related to this specific bug of “@” in paths here at Galaxy Help:

:point_up_2: this first one is about maker too (V 2.31.10):

Possible unintended interpolation of @2 in string at /media/vol2/home/galaxy/galaxy/database/dependencies/_conda/envs/__maker@2.31.10/bin/../lib/5.26.2/x86_64-linux-thread-multi/Config_heavy.pl line 260.
  Possible precedence issue with control flow operator at /media/vol2/home/galaxy/galaxy/database/dependencies/_conda/envs/__maker@2.31.10/lib/site_perl/5.26.2/Bio/DB/IndexedBase.pm line 805.
  error: executing task of job 1007802 failed: execution daemon on host "node11" didn't accept task

The others :

Thanks so much for finding others with the same problem, @David. The fact that this glitch doesn’t happen every time someone uses one of these tool makes me wonder if this problem really is caused by insufficient memory allotment, like @jennaj said.

If that’s the case, would it be best to just rerun the job until it works? Seems like a bad use of time/resources.

Or, if going into the code would be best, could someone show me how to do that? I’m a newb at Galaxy.

I suppose it’s good to run into these issues on the tutorial before hitting these walls on my data.

Jared,
I don’t know if rerun can help. I also do not suggest you going to the code, instead, let someone from Galaxy take a more detailed look.
Maybe you can try other instances of Galaxy and see if you have better luck.
Indeed, tutorials are very nice to gain experience, good or bad.

Could someone from Team Galaxy help resolve this error when using Maker on Galaxy Main?

Possible unintended interpolation of @2 in string at /cvmfs/main.galaxyproject.org/deps/_conda/envs/__maker@2.31.11/bin/…/lib/5.26.2/x86_64-linux-thread-multi/Config_heavy.pl line 260.
Possible precedence issue with control flow operator at /cvmfs/main.

As before, there is a message that says:

Required metadata values are missing. Some of these values may not be editable by the user. Selecting “Auto-detect” will attempt to fix these values.

But I’ve tried auto-detecting the metadata, and it doesn’t help.

I’ve also tried running this on another instance, Galaxy Europe, but got the same interpolation error. (By the way, I’m now using my data rather than the tutorial mentioned above.)

Thanks for any ideas.