Tool form does not list expected indexed reference genome: Solution -- assign the "database" to the inputs

Hello, I am going through “De novo transcriptome reconstruction with RNA-Seq” tutorial. I can not cash mm10 reference genome at GFFCompare step: “Use Sequence Data” : Yes
“Choose the source for the reference list” : Locally cached
“Using reference genome”* : ‘Mouse (Mus Musculus): mm10’

How do I import mm10 into Galaxy? see snapshot:

1 Like

Welcome, @irinastl

The list of available genomes is based on the assigned “database” of the inputs. Maybe you need to assign the “mm10” database to those?

The database can be assigned during Upload. Or, for already loaded data, click on the pencil icon to reach the Edit attributes forms. For your case, the first tab has the option of assigning the genome/build “datatype”. Type in “mm10” to search the list. Make sure your data really is from this same exact build, and that the assigned datatype is correct, or expect problems.

FAQs:

This tool is technically from a deprecated tool suite but I don’t know of any specific issues with it. And I just checked it at Galaxy Main https://usegalaxy.org and mm10 is indexed for it.

Hope that helps!