Trinotate error resulting in "The job creating this dataset has been resubmitted"

I ran into this error when running Trinotate on Galaxy Europe:

The job creating this dataset has been resubmitted

An error occurred with this dataset:

This job was resubmitted to the queue because it encountered a tool detected error condition on its compute resource. memory memory memory memory * Running CMD: wget "ftp://ftp.uniprot.org/pub/databases/uniprot/current_release/knowledgebase/complete/unipr

Does this mean the job is running again, or do I need to resubmit?

2 Likes

@jaredbernard You can see if the job is running by its color:
https://galaxyproject.org/support/how-jobs-execute/#dataset-states

You can try rerun it.

Thanks, @David. The error message was red, but the phrasing made me think it was going to automatically rerun. Also I thought Galaxy Europe sometimes reran jobs that fail. But I waited several hours and it was not rerunning, so I started it again myself.

I noticed a few others have posted this error for various tools, but no one specifically addressed what this error message means, so I thought it would be good if a help issue specifically asked the meaning of the message.

1 Like

@jaredbernard, I agree. I’ve found a more direct answer from the gitter / usegalaxy-eu/Lobby:

Helena Rasche @erasche jun 19 2019 09:01
This means the job has failed, and we have automatically retried to run it with more memory.
If your jobs fail, please check the (i) information icon, and see the stderr or stdout, and if those do not tell you the issue, then please usethe bug report icon to submit errors

Maybe this would be a more official answer for now

2 Likes

Thanks for the answer @David and @erasche. Unfortunately, my restarted job ended with the same error message.

Any chance your input is not ok?

I’ve wondered that, as a possibility. But I think it is okay.

I’ve done things virtually identical to the workflow in this de novo transcriptome assembly tutorial and advice on this Galaxy Help page, but using my own data.

@jaredbernard Can you provide the full error text message and the bug text?

Maybe it is similar to what happened here:

Thanks for looking into this, @David.

The message in my first post was my whole error message.
Under Tool Standard Error, the message is:

Error, cmd: wget “ftp://ftp.geneontology.org/pub/go/external2go/pfam2go” died with ret 1024 at /usr/local/tools/_conda/envs/mulled-v1-d301214ea0391aec86b2f63c2c1ac14ef0598be5ae4d143b7405cc0414beaa71/lib/site_perl/5.26.2/Pipeliner.pm line 102.
Pipeliner::run(Pipeliner=HASH(0x55d0b25ea838)) called at /usr/local/tools/_conda/envs/mulled-v1-d301214ea0391aec86b2f63c2c1ac14ef0598be5ae4d143b7405cc0414beaa71/bin/Build_Trinotate_Boilerplate_SQLite_db.pl line 120

Hi there,
I’m having a similar error:
Error, cmd: wget “ftp://ftp.geneontology.org/pub/go/external2go/pfam2go” died with ret 1024 at /usr/local/tools/_conda/envs/mulled-v1-d301214ea0391aec86b2f63c2c1ac14ef0598be5ae4d143b7405cc0414beaa71/lib/site_perl/5.26.2/Pipeliner.pm line 102.
Did you find any solution?

1 Like

Update

Issue ticket: Bug: Trinotate (Galaxy Version 3.2.1) · Issue #3875 · galaxyproject/tools-iuc · GitHub


HI @melisa123

This looks like an actual bug. Specifically, the environment created for the job is failing to retrieve one of the required inputs (from a 3rd party’s site).

You are working at UseGalaxy.eu, correct? If so, please submit your error as a bug report and include a link to this topic at Galaxy Help in the comments. Both provide technical context. Step 4 here explains how: Troubleshooting errors

2 Likes