AnnotateMyIDs Fatal error

Hi, I’m trying to run annotatemyid on my featurecounts table. I put as input ID type Entrez, but a error occurs .
Fatal error: Exit code 1 ()
Error in scan(file = file, what = what, sep = sep, quote = quote, dec = dec, :
line 2 did not have 8 elements
Calls: read.table -> scan

Can anyone help me?


1 Like

Hi - On the annotateMyIds tool form, try setting the option “File has header?” to “Yes”.

Tried but nothing, same error.This is the first part of my table. !

1 Like

Ok, thanks for trying that. I ran a few tests, at different servers and using different versions of the tool – all fail in a similar way. I’m not sure why so will reply again once known.

To use the tool now, first run the tool Remove beginning of a file to remove the first line (header), then run the tool annotateMyIds. That worked in my tests, across servers and tool versions.

Appreciate the follow up – this was unexpected!

Update: This was a bug. I opened a ticket for the correction here if interested:

Until that is completed, continue to remove header lines from any inputs to this tool, no matter which server or tool version you may be using.

Thank you very much!

1 Like