Local Galaxy CVMFS - BWA/BWA-MEM fails to locate the index files


I am trying to build a local Galaxy server (basically followed the training materials up to step 7, version 22.01).

My problem is that when I run BWA/BWA-MEM I receive the following error:

As far as I can tell the data tables and CVMFS seem to work properly.

ubuntu@galaxy-server:~$ ls /cvmfs/data.galaxyproject.org/byhand/hg38/hg38full/bwa_index_v0.7.10-r789/
hg38full.fa  hg38full.fa.amb  hg38full.fa.ann  hg38full.fa.bwt  hg38full.fa.pac  hg38full.fa.sa

Any help is appreciated!

Hi @OtimusOne

Would you please try again now? It looks like the CVMFS server had a little trouble around the time you posted. https://status.galaxyproject.org/

Other than that, things to check are:

  1. Using the most current version of a tool: true
  2. Using the most current version of Galaxy: ?? Should be January 2022 Galaxy Release (v 22.01) — Galaxy Project 22.01.2.dev0 documentation
  3. The indexes are connected. One of these:

If that is not enough help, please post back the relevant configurations lines and we can bring in some expert help for more review.

It also might be helpful to test this on another index or two, just to see what happens. Maybe a different genome’s BWA index and a tool that uses a different index from this same genome.

Let’s start there :slight_smile:


I’ve managed to track down the issue to Singularity. I’ve rolled back my configuration to the CVMFS tutorial and BWA works properly. It’s after I apply the changes from the Singularity tutorial that it fails to locate the index files. I assume that the /cvmfs directory isn’t accessible to the containers.
Seems like adding < env id=“SINGULARITY_BIND”>/cvmfs< /env> did the trick.

Update: After I got BWA working with Singularity I tried to use snpEff Download for hg38 and got the following error.

/usr/local/bin/snpEff: line 8: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8): No such file or directory
00:00:00	SnpEff version SnpEff 4.3r (build 2017-09-06 16:41), by Pablo Cingolani
00:00:00	Command: 'download'
00:00:00	Reading configuration file 'snpEff.config'. Genome: 'hg38'
00:00:00	Reading config file: /srv/galaxy/jobs/000/139/working/snpEff.config
00:00:00	Reading config file: /usr/local/share/snpeff-4.3.1r-0/snpEff.config
00:00:00	done
00:00:00	Downloading database for 'hg38'
00:00:00	Connecting to http://downloads.sourceforge.net/project/snpeff/databases/v4_3/snpEff_v4_3_hg38.zip
00:00:01	ERROR while connecting to http://downloads.sourceforge.net/project/snpeff/databases/v4_3/snpEff_v4_3_hg38.zip
java.lang.RuntimeException: java.net.UnknownHostException: downloads.sourceforge.net
	at org.snpeff.util.Download.download(Download.java:178)
	at org.snpeff.snpEffect.commandLine.SnpEffCmdDownload.downloadAndInstall(SnpEffCmdDownload.java:32)
	at org.snpeff.snpEffect.commandLine.SnpEffCmdDownload.runDownloadGenome(SnpEffCmdDownload.java:86)
	at org.snpeff.snpEffect.commandLine.SnpEffCmdDownload.run(SnpEffCmdDownload.java:72)
	at org.snpeff.SnpEff.run(SnpEff.java:1183)
	at org.snpeff.SnpEff.main(SnpEff.java:162)
Caused by: java.net.UnknownHostException: downloads.sourceforge.net
	at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
	at java.net.Socket.connect(Socket.java:589)
	at java.net.Socket.connect(Socket.java:538)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:211)
	at sun.net.www.http.HttpClient.New(HttpClient.java:308)
	at sun.net.www.http.HttpClient.New(HttpClient.java:326)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1202)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1138)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1032)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:966)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1546)
	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1474)
	at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
	at org.snpeff.util.Download.download(Download.java:117)
	... 5 more
00:00:01	Logging
00:00:02	Done.

Once again I rolled back the Singularity changes and snpEff Download works properly. It seems that I am trying to use Singularity in ways which are not covered by the tutorial. Are there any further resources that can help on this topic?

The admin docs have the full details. Navigate to the Galaxy release you are running for a match. Containers for Tool Dependencies — Galaxy Project 23.0.dev0 documentation