Problem with DESeq2

Hello everyone,
Can you tell me how can I solve this problem?

1 Like

Hi @ive_s

This looks like an input problem.

Things to check. The first two are most likely to solve this specific error.

  1. Content of input datasets. Examples are on the tool form. Be sure to input each dataset just once.
  2. If count files have headers, be sure to check the box for “inputs have headers”.
  3. This FAQ has additional help (but I don’t think you are running into these problems): Help for Differential Expression Analysis
  4. I added a tag to your post about prior Q&A troubleshooting using this tool for additional context/help.

Hi @jennaj ,
I checked first two things from your list, but I still get the same error. My count files have headers, and box for that is checked by default. I went trough my samples, there are no duplicates. This is how my count files from FeatureCounts look like:

In box Choice of Input data I put option count.

Thank you for help!

1 Like

Hi @ive_s

Thanks for checking and posting back.

The problem is with the count values. Those should be whole numbers (integers), not decimals. Check your settings with Featurecounts – the default output are counts by “gene_id” and will produce whole numbers – and that is required by the Bioconductor tools.

Update: Hum, I might be wrong about that. Looks like EdgeR accepts fractions but DESeq2 does not. Maybe use EdgeR instead? Or you can use text manipulation tools in Galaxy to round off the values.


Tutorials: Galaxy Training!

I solved this by rounding numbers in RStudio, and then uploading data back on server. It worked! :slight_smile: