psortb error on usegalaxy.eu

Hi,
I was trying to run psortb (subcellular localization prediction too) on usegalaxy.eu

I get the error

/bin/sh: line 1: psort: command not found
Traceback (most recent call last):
  File "/opt/galaxy/shed_tools/toolshed.g2.bx.psu.edu/repos/peterjc/tmhmm_and_signalp/e1996f0f4e85/tmhmm_and_signalp/tools/protein_analysis/psortb.py", line 241, in <module>
    sys.exit(
TypeError: exit expected at most 1 argument, got 2

Tool Exit Code 	1

Thanks!

1 Like

Hi @microfuge

As a guess, check the number of columns in your data? Do that on the Dataset Details “i” icon view, since that can reveal a bit more than clicking on the “eye” icon.

If you solved this, please let us know! I’m sure someone else will have this problem, search here, and appreciate learning what was going on and maybe how to solve it. :slight_smile:

Hi @jennaj ,

Thanks for your reply. The input dataset is a protein fasta. It looks like a problem with the tool dependency. I have made the history public with the history id being Galaxy

Hi @microfuge

Thank you for posting the shared history, very helpful!

There is some problem with the tool, likely related to dependencies, and I’ve reported it to the EU administrators. Update → Add conda scheduling tags for the tool psortb by sanjaysrikakulam · Pull Request #1231 · usegalaxy-eu/infrastructure-playbook · GitHub

That is the only UseGalaxy server I could find the tool installed at… so you might want to consider alternatives, at least for now. SignalP seems promising! Both are from the same original author. I never knew or can’t remember the history/timelines for these two but am wondering if psortb was an earlier, or rather, a simpler, iteration. You might be able to find discussion online or in the associated publications about that if curious.

Hope this helps and thanks for following up!

1 Like

@microfuge can you please try it again?

I assume 2 problems. You are correct that the stacktrace is a dependency problem. This tool assumes Python2. This should now be fixed.

Howevery, the code path leading to the stacktrace indicates an error before that. So it can be there is a 2 error hidden, maybe concerning your inputs.

Let us know if you can proceed.

1 Like

Thanks @jennaj , Thanks @bjoern.gruening ,

Thanks for looking into this. I was not aware of signalP, will take a look into it.
Unfortunately, the error persists. I tried with a protein with known prediction in psortb database.

The new runs are also in the public history Galaxy