Scanpy RunPCA on tutorial, erroring out for me

I’m going through the tutorial Filter, Plot and Explore Single-cell RNA-seq Data -, and am up to the point where it says:

Hands-on: Calculate Principal Components

I’m doing everything it says, I’m using the right output file, which has the right cell x gene numbers, but I’ve tried to run it in 1.8.1 + galaxy 0 three times and it’s failed each time.

Here’s my history: click

Any help much appreciated :slight_smile:

Hi @miRlyKayleigh

Two things that would help:

  1. Re-share the history so that all of the included datasets are accessible by others. When working at the EU server, you need to explicitly share each new/old dataset in an existing history or set the User → Preferences → Set Dataset Permissions for New Histories to default share new histories with everyone. They would still need to know or guess the share link then try to guess what you were doing :slight_smile: and the US server works this way by default (but can be toggled to the EU default).
  2. Leave all inputs and outputs undeleted if you want feedback about them. Any deleted or purged datasets will be dropped from the shared history view. This is probably why you don’t have a reply yet – others can’t see the errors.

Plus optionally:

  1. Consider trying this first:
  • Get a copy of that tutorial’s workflow into your account. Find the URL(s) for any associated workflows linked in the box at the top of any tutorial. That view will have these instructions #importing-a-workflow
  • Start up a new history and load the starting data into it.
  • Run the workflow and consider sending the output to a new history. Keep the workflow name intact and add in a number or date.
  • If the workflow “works”, then the tool doesn’t have a problem. Instead, the inputs or settings have a problem, or one of the prior steps had a problem. This should help to isolate and troubleshoot what is going wrong.
  • Different Galaxy servers host different versions of tools. If the server where you are working is not in the listing under “available at these Galaxies” drop down at the top of the tutorial, where you are working might not be supported (temporarily, or ever). The listed servers are a “technical match”. Sometimes that matters and sometimes not. For fewer technical issues, work at a listed server.
  • If you need more help, please share back the history again.

As an independent test, I started up a paired set including this tutorial’s workflow + history at the same server where you are working. It will take some time to run, and the new datasets created while the workflow runs might not share by default (will re-share once done).

Let’s start there!


The test finished successfully, so the tutorial data and tools are all okay.

It now looks like you have a successful run for this tool/step, too (dataset 34), and that the upstream tool Scanpy NormaliseData was when the data content problem was introduced.

Glad that worked out!