An error occurred while running the tool Braker3

it is a local installed Galaxy server , the error is related to braker3

Hi @Naibin_Duan

I’m not sure from that error message whether the error is related to the data inputs or some configuration problem with the tool installation.

If you can reproduce this at a public Galaxy server, or if you cannot, that would be the next step.

Try testing at for this one (other UseGalaxy servers do not host it yet) → Link to tool braker3/3.0.8+galaxy0

If reproducible, we can probably help more here. Please share back the job details page from the error dataset, and make sure the history is set to a shared state so we can see the details. Or, you can post the history link and note which dataset to look at. Make sure that the inputs/outputs are undeleted. How to share is in here How to get faster help with your question

Thank you. I am using the Galaxy platform you provided me with,uploading y relevant data and running braker3 to see if it still encounters the same errors

1 Like

Hey there, Dear Jennaj much appreciated for the backup. I’ve been hacking away on your eu-galaxy platform you recommended, dropped in a genome waiting to get its annotations sorted, along with a bam file straight out of an RNA-Seq mapped against said genome(sd0003.anch.genome.fa). Fired it up on the platform and boom, hit this snag (see attached pic). But, heads up: the glitch I’m hitting on eu-galaxy doesn’t match the one I’m getting in my own local galaxy setup.

history shared

I know Braker3 needs a lot of dependencies. Perhaps it is easy to install it but difficult to run smoothly.

1 Like

Hi @Naibin_Duan

I’m not able to access your history. I’m still willing to take a look if you want to try sharing it again.

And, I ran a test job last week, and mine also failed but for a different reason as you got at EU but it seems the same as what you got locally. I’ve reported that via a bug report to the EU server administrators. You could do the same to give them another use case. This is my testing history if you want to compare Galaxy.

I also shared a link to this post with the admins, so maybe they will get back to us here :slight_smile: If nothing happens for another week, please ask for an update.

Hi @Naibin_Duan

We have fixed it in the latest version. Please rerun your job.

Thanks @Naibin_Duan :rocket:

I’ve started up a rerun of my test in the same history as before. It is still running but would have failed by now if the same problem was presenting. Great!

Hello Jennifer, I’m very sorry for the late reply. I don’t know why I failed to share the history with you, it’s likely because I didn’t click the “publish” button. I have now published it.

I also saw the error alerts for the braker shared with me, and it’s the same error that I sent you earlier:

Possible unintended interpolation of @3 in string at /usr/local/tools/_conda/envs/__braker@3.0.7/lib/perl5/5.32/core_perl/ line 246. /data/jwd02f/main/067/033/67033833/ line 27: /gmes/

The main issue for my local Galaxy server is how to install the GeneMark software package under the administrator user.

thanks so much @sanjay_srikakulam I am currently rerunning it to see how it goes

1 Like

Yes, Jenifer, I saw the history you shared with me. The error you discovered in eu-galaxy is identical to the one I found in local galaxy.

The error you encountered running Braker in eu-galaxy (Braker version 3.07):

The error I encountered running Braker in local galaxy (Braker version 3.08):

The error I encountered running Braker in eu-galaxy (Braker version 3.08):

I hope you can see my history through this link. I found that we both use eu-galaxy, my Braker is version 3.08; while yours is Braker version 3.07?

Galaxy (

Once again, thanks to @sanjay_srikakulam. I ran it again. Now, there hasn’t been any error.

1 Like

Hi @Naibin_Duan

Check the tool repository and update that in your local as needed as a first pass solution. Make sure you are using managed dependencies for this to replicate the same job environment as the EU server.

Let us know how that goes. If not enough, maybe @sanjay_srikakulam can explain more about what was needed to resolve the problem at the public server? Some administrative change not related to the tool wrapper?