AnnotatemyIDs Key input error

Hi,
I’m trying to input a file from kallisto and I keep getting a key input error on the annotate my IDs function. My headers are called target_id_eightfiveoneseven and est_countseightfiveoneseven. The file has two rows; the first column is the transcript ID from ensembl and the second is the est count column. The transcript names look odd for example one looks like ENST00000631435.1. Even though I select the ensembl transcript ID it still doesn’t seem to recognize the input.since I get a key error.
Error in .testForValidKeys(x, keys, keytype, fks) :
None of the keys entered are valid keys for ‘ENSEMBLTRANS’. Please use the keys method to see a listing of valid arguments.
Calls: select … select -> .select -> testSelectArgs -> .testForValidKeys

My table headers are unique and are called target_id_eightfiveoneseven and est_counts_eightfiveoneseven.

Does anyone spot errors in the names of the input files?
Thanks!

1 Like

*Update- I’ve Switched the name of the identifier in column one to ENSEMBLTRANS but I still get the same key error message. I left my est_count title the same.

K

1 Like

Hello @Kiera_Drew45

Try removing the .N (where N is some number) from the identifiers.

Tool choices include: Replace parts of text

Hope that helps!

Hi @jennaj,

I’ve tried to remove the number following the decimal place individually. The annotate my ids function runs, but the output just gives NA for geneid & symbol. For whatever reason, the mapping function doesn’t work if I edit the ensembltrans ID column.

Would it be easier to use a different reference transcriptome file? Or do all cdna sequences have the same format as ENST00000631435.1? I’m using Homo_sapiens.GRCh38.cdna.all.fa from Ensembl. ftp://ftp.ensembl.org/pub/release-97/fasta/homo_sapiens/cdna/

Thanks for your help!

K

1 Like

Sorry to hear that didn’t work. Just to double-check, make sure you are removing the “dot”, too.

You could also try Uniprot instead. That will also need the dot+version removed from the IDs. Ensembl choices are under the option Choose your database category (FROM):

Hope that works out (it should). May take some test runs to find out which options (to + from) return the results you need.

Thanks!