Stringtie not outputting counts anymore


So yesterday I was able to use stringtie to get gene and transcript counts from my aligned BAM files with no issues. Today I tried to run new samples and I was able to get assembled transcripts but no counts. I figured this was an issue with my new files. So I took the files that worked perfectly yesterday and ran stringtie on them again (same settings, files, etc.) and now these are also not outputting any counts. I’m honestly stumped on this one and not sure if it is just an issue with the site at this point. Any advice would greatly help my sanity. Thank you.

Hi @Stephen_Willis
I tested StringTie on and got the count files. The tool was tested with a gene annotation file in history with Use reference transcripts only set to Yes, and without annotation. In the latter scenario it produces only gene count file.
How did you submitted the job, by clicking on the tool in the tool menu or by re-run? If through the tool menu, have you activated the counting option? It is off by default.

Kind regards,


I tried to do it by re-run and it did work now, but also changing:

“Output gene abundance estimation file? = True”

Also worked. Is that what you meant by activating the counting option? Because that was set to false in my other run (which worked). I mean it is working now, which is really all that matters but I’m still confused.

Hi Stephen,
I am sorry for the confusing explanation. With the default settings StringTie only produces a gene annotation file. It can produce count and abundance files, as additional outputs. For example, you can enable output of abundance estimation files, as in your reply. To get counts, try gene annotation in your history, and change Output files for differential expression? to DESeq2/EdgeR/limma-voom.
For counting I use dedicated tools, such as featureCounts.
Kind regards,